Bienvenidos

Home Forums Foro de soporte en español Bienvenidos

Viewing 15 posts - 16 through 30 (of 37 total)
  • Author
    Posts
  • #196
    JorgethJorgeth
    Participant

    Buenas a todos,

    Soy uno mas haciendo pruebas con la raspberry Pi3 y el proyecto del termostato.
    Solo he podido llegar hasta instalar,(o semi instalar el SO android things en la sd y lanzarlo en la raspberry.

    Lo unico que veo es una pantalla con el logo de androidthings en verde y gris con una ip que es la que coge por dhcp y un apartado que si le doy me salen los gpio disponibles de la raspberry, pero no se seguir, no tengo mucha idea de programación.

    Alguna idea para continuar con el proyecto?

    Muchas gracias

    #197
    adminadmin
    Keymaster

    Hola Jorge, bienvenido.

    Pues lo que has obtenido es normal. Digamos que has instalado una imagen del sistema operativo “vacía”, es decir, no hay ningun programa instalado en tu Raspberry Pi (aparte del sistema operativo).

    Lo que tendreis que hacer tanto tu, como Tatinho, será instalar una imagen de sistema que yo os proporcionaré, en la que ira incluido el programa del termostato para la Pi. Peeeeeero, estoy resolviendo unos problemas de ultima hora. Resulta que si instalo el programa desde Android Studio funciona, pero en cuanto creo la imagen ya no funciona. Bueno, cosas del directo.

    En cuanto tenga una imagen que funcione os avisaré tanto a ti, como a Tatinho.

    Jorge, una pregunta, ¿tienes los perifericos (sensor, relay), necesarios? ¿Como tienes pensado montar el sistema?

    Un saludo

    #232
    pirriboypirriboy
    Participant

    Hola Roque,

    A ver si me puedes pasar lo necesario para empezar ha hacer pruebas,imágenes, apk etc. si me confirmas el esp32 lo compro ya.Tengo todo menos el esp32. Por que el nodo no funcionaria con un esp12 o nodemcu. La lentitud del yun me mata y quiero ya dejar puesto algo mas estable.

    Saludos,
    Pirriboy

    #233
    adminadmin
    Keymaster

    Hola Pirriboy,

    estoy dandole los ultimos retoques a la beta. Tengo un par de problemillas que han de solucionarse antes de pasaros la imagen. Con suerte este fin de semana os la pasare.

    Entiendo que el yun te parezca lento, pero vas a sustituirlo con una version beta, asi que no te esperes que todas las ¡¡¡¡funciones están programadas ya!!!

    Tema nodos inalámbricos. Yo lo he programado con un ESP32. Los materiales que he utilizado los teneis en la siguiente pagina.

    ¿Que comprar?

    Todavia no esta traducida al español, a ver si puedo hacerlo en los próximos días.

    Me preguntas por un nodo esp12 o nodemcu. Pues te dire una cosa: si consigues que el sketch que he desarrollado para el esp32 (y que ya colgare en la web en cuanto pueda), funcione en un esp12 o un nodemcu, pues entonces la respuesta es si. En realidad, el único requisito que tienen que cumplir los nodos es que cuando la Pi acceda a ellos por la ip, con http://ipdelnodo, este conteste con un objeto json parecido al siguiente:

    {
    “celsius”:”20,
    …. otros datos.
    }

    Ahora mismo no tengo en la cabeza como es el objeto json que responden los nodos, pero ya lo miraré. Por lo tanto, me atrevo a decir que si, que se pueden incluir otro tipo de microcontroladores al proyecto.

    Incluso no sería descabellado poder usar otro tipo de sensores de temperatura, siempre que tengan una api que les permita ser consultados.

    Pero lo iremos viendo poco a poco. Es mucho curro para uno solo!

    Un saludo

    Roque.

    #235
    pirriboypirriboy
    Participant

    Buenas,

    Pues me comprare un par de ESP32 para el nodo inalanbrico y otro para el rele.

    Sobre lo del json lo podriamos mirar y usar nodos hasta con un ESP01. Como seria cadena de un nodo del jso “ipdelnodo/json/…..”

    Un saludo.

    #239
    adminadmin
    Keymaster

    Hola a todos,

    he abierto otro hilo donde explico como instalar la beta 001. El enlace de descarga os lo mando por email privado.

    Version beta 0.0.1

    Si no os importa, lo relacionado con la instalacion de la beta y los problemas, los tratamos en ese hilo.


    @Pirriboy
    : esa captura de pantalla que has subido, ¿a que se corresponde? Es algun tipo de sketch para medir temperatura estandar, o es algo que has desarrollado tu?

    Al final, tan “solo” tendria que adaptar mi programa para que entienda el formato del json que cada sensor le proporciona, y podria ser compatible con multitud de placas y sensores…

    #316
    pirriboypirriboy
    Participant

    Buenas,
    La captura no la quería poner, se me colo,te queria comentar y al final no te comente y se quedo la captura, estuve mirando la wiki de un firmware para los esp, es muy configurable, muy sencillo de conigurar, se le pueden poner multitud de sensores por muy bajo precio.Es una captura del json del firmware para los esp1…esp12. El firmware es este, https://www.letscontrolit.com/wiki/index.php/ESPEasy. Si se pudiese adaptar seria muy guay.
    He tenido dos dht22, el bme280 y un bmp085,con este firmware, con esps01 y esps12 funcionando con un domoticz como servidor durante meses y funcionan muy bien.

    Saludos.

    #317
    Javier TatoJavier Tato
    Participant

    Buenas Roque,

    La aplicación de android va muy fluida, actualiza muy rápido. Mucho mejor que con la pantalla.
    Comparado con el yun va muy rápido a la hora de conectarse.
    De momento no lo tengo conectado a la caldera, tengo al yun por tener los programas.

    #318
    adminadmin
    Keymaster

    @Tatinho: Tiene muy buena pinta el firmware EspEasy. Me lo apunto y lo estudiaré a ver como podemos beneficiarnos del tema.


    @Pirriboy
    : no me olvido de ti. El fin de semana tengo pensado liberar otra version, que muestra los errores intentando conectar con el sensor cableado, para ver si nos ayuda en tu caso.

    #319
    adminadmin
    Keymaster

    Hola compis,

    va por el aire la actualizacion 0.0.4. Esta actualizacion solo tiene dos novedades:

    – los de google han actualizado el firmware, de la version 0.6 a la 0.6.1. Veremos si han roto algo 😉
    – en mi app, cuando no se detecta el sensor conectado, se muestra en la lista el mensaje de error que ha proporcionado el sistema operativo, por si ayuda en algo.

    Ya me contareis…

    #320
    pirriboypirriboy
    Participant

    Hola,

    Actualizado a la 0.0.4, cuando hago busqueda de nodos aparece lo de la foto y no detecta nada.
    https://photos.app.goo.gl/j3dc9UUzn7e2QbTj2

    Saludos.

    • This reply was modified 6 years, 6 months ago by pirriboy.
    #323
    adminadmin
    Keymaster

    Por las pruebas que he hecho, hay dos situaciones posibles.

    La primera es cuando se ha conectado mal, o no se ha conectado, los cables de gnd y/o VCC al sensor. En ese caso la app no detecta nada de nada, como es lógico.

    El segundo caso es cuando habiendo conectado correctamente el cable de gnd y vcc, no están bien conectados los dos cables de datos. En ese caso se muestra el error que sale en la foto.

    A mí me ha pasado alguna vez, y desconectando los cables de protoboarding y volviendo a conectarlos se ha solucionado.

    Supongo que ya has probado con otros cables, etc…

    #324
    pirriboypirriboy
    Participant

    Si, he cambiado los cables, los he reconectado un monton de veces, con los mismos cables en un esp12 funciona bien. No se es raro.

    #325
    Javier TatoJavier Tato
    Participant

    Buenas Roque,

    Este fin de semana con la actualización 0.0.4 me ha entrado en un bucle y da siempre error de Google Play services has stopped.
    No llega a arrancar la app.
    Ya tengo otro bme280, ya lo conecte para las pruebas

    #326
    adminadmin
    Keymaster

    Hola,


    @Tatinho
    : perdona, he estado haciendo cosas en el servidor, y es por eso que se te reinicia la app, porque la configuración que tiene ya no esta de acorde con el servidor. Si fuera un telefono, con borrar los datos de la app llegaria, pero en la Pi no se puede hacer eso…, asi que…

    Aparte de eso voy a publicar en las proximas horas, la version 0.0.5, tanto de la app de la PI, como de la app del movil.

    Respecto a los sensores no detectados, no se que deciros. Estoy sin ideas. ¿A vosotros se os ocurre algo?

    Un saludo

Viewing 15 posts - 16 through 30 (of 37 total)
  • The topic ‘Bienvenidos’ is closed to new replies.