Relé no funciona en el pin Vin 5V

Home Forums Foro de soporte en español Relé no funciona en el pin Vin 5V

Viewing 10 posts - 16 through 25 (of 25 total)
  • Author
    Posts
  • #1263
    adminadmin
    Keymaster

    Por cierto, deduzco que lo tienes todo funcionando entonces?

    Si te interesa probar la nueva version que esta por salir, mandame un privado.

    Un saludo

    #1264
    RAntonioRAntonio
    Participant

    Buenas,

    Realmente si perdemos el suministro eléctrico en la vivienda, la caldera quedara también sin servicio, otra cosa es que tengamos circuitos diferentes o u SAI que permita alimentar la caldera y el módulo de forma independiente, obviamente mejor tener el relé adecuado.

    De momento solicito un par de ellos, que son baratos y tengo la necesidad de controlar la alimentación de la caldera con uno y con otro la activación del quemador por temperatura, o sea termostato ambiente.

    Sigamos, pues.

    #1265
    adminadmin
    Keymaster

    De nuevo tienes razón, si nos quedamos sin electricidad, lo normal es que la caldera tambien se quede sin electricidad. Pero ¿podria ocurrir que la fuente de alimentacion del ESP32 pete, y este se apague? A mi me paso que el cargador de movil que usaba con el ESP32 murió, y el ESP simplemente se apagó.

    Bueno, quedo a la espera de noticias. Saludos!

    #1266
    navigtoornavigtoor
    Participant

    Buenas.

    RAntonio, aquí tienes un enlace de un relé High Level Trigger:

    https://www.banggood.com/5V-1-Channel-Level-Trigger-Optocoupler-Relay-Module-For-Arduino-p-915614.html?rmmds=myorder&cur_warehouse=CN

    Hola de nuevo Roque. Ya he recibido el nuevo ESP32. Lo tengo de nuevo en marcha pero tampoco me funciona el relé. NO sé si será mala conexión o qué. Seguiré mirando.
    Otra cosa, Roque, cuando puedas, a ver si puedes implementar dos pulsadores (uno de subida y otro de bajada) en las apps.

    Gracias.

    • This reply was modified 5 years, 3 months ago by navigtoor.
    #1268
    navigtoornavigtoor
    Participant

    Después de revisar todo bien, tengo la impresión de que es cosa del sketch. Me explico. Cuando subo la temperatura para forzar la activación del relé, debería aparecer la “llamita” que indica el encendido y poner rele “ON” en la app, aunque no activase físicamente el relé. Entonces sí sería un problema de mala conexión o de relé defectuoso, etc. Pero no aparece nada en la app, como si no se activase nada.

    No sé qué puede ser…

    #1269
    navigtoornavigtoor
    Participant

    Ya está solucionado. Le cambié el pin de salida al 21 por que me era más cómodo para las conexiones. Le he vuelto a poner el pin que venía en el sketch original (pin 27) y ahora funciona. no sé si tiene algo qué ver las funciones de los pines para que funcione con unos y no con otros.

    #1270
    RAntonioRAntonio
    Participant

    Buenas

    “¿podría ocurrir que la fuente de alimentación del ESP32 pete, y este se apague? “.Leches, pues claro que puede pasar, y menudo lío, sobre todo en segunda residencia con la caldera gastando y nosotros fuera de casa.

    Ayer solicite los relés al enlace que puse, los pedí con un gasto de envío de 3’5€ para que me llegase esta semana, y jopetas…. Hoy ya tengo el Relé en casa.

    Lo monto y funciona fenomenal (el anterior estaba permanentemente activo). Eso si con la lógica inversa, cuando tengo la llamita en la APP el relé no está excitado y cuando la llamita se apaga el relé se excita, esto me obliga a cambiar la lógica del contacto. Por consumo eléctrico es mejor que a llamita apagada, relé no excitado.

    navigtoor, edite el sketch para excitar relé por otro ping (el 23) y funciona la llama en la APP y conmutación del relé, edité otra vez el sketch lo cambié a la 27 e igualmente funcionó.

    Si desde Arduino abres una consola de monitor serie podemos ver como intercambia datos ESP32 con la APP y ver los grados y el estado del relé, por si te sirve de ayuda y testear si ESP los envía hacia la nube.

    Lo de poder tener un segundo relé sería interesante para controlar un segundo método de climatización, como por ejemplo una bomba de calor, pues puedes arrancar por la mañana con la bomba que enseguida caldea y tener un rendimiento impresionante y mantener la parte confortable con los radiadores de agua, yo lo tengo así aquí y es una gozada/ahorro.

    En fin… Viento en popa que en casa no hace frío 😉

    #1271
    adminadmin
    Keymaster

    Me alegro que todo vaya encajando poco a poco.

    Yo no os recomiendo cambiar los pines en el código fuente, y mucho menos cambiarlos y soldarlos. Si los cambiáis, tendréis que acordaros cuando haya una actualización, y me parece un rollo.

    De hecho hay una actualización de los Sketches que publicaré con la nueva versión de la app en un par de semanas. Y es importante porque arregla un bug, poco probable pero sería un bug molesto.

    #1272
    RAntonioRAntonio
    Participant

    Si, si, es mejor tener la programación tuya, por eso contaba mi experiencia basada en la suya a navigtoor y volver a probar con el pin 27. Asi es como yo lo dejé finalmente

    Qué bien, cuando todo va bien.

    #1273
    adminadmin
    Keymaster

    @navigtoor: Los pulsadores ya están implementados. Le estoy dando los ultimos retoques a la proxima versión, y cuando este lista la publicaré como beta, y deberías recibirla. Aun tardaré unos dias, porque tengo que hacer pruebas con un relay low level. Ya os mandare un email a los beta testers con las novedades.

    Un saludo

    Roque.

Viewing 10 posts - 16 through 25 (of 25 total)
  • You must be logged in to reply to this topic.